vendredi 26 février 2016

Des nuages facile et rapide

Cette semaine on va voir une méthode simple et très efficace pour faire des nuages dans Cinema 4D, simplement avec une image et un cloneur et quelques réglages, c'est une méthode qui à l'avantage d'être très rapide à calculer en ayant un rendu plutôt chouette ^_^ place à la vidéo...


la scène du tutoriel avec la texture de nuage dedans :


et n'hésitez pas à allez jeter un œil sur les chaînes des partenaires :

MHSTuts :
https://www.youtube.com/user/myhiddensintuts/featured

Lil Guy Design :
https://www.youtube.com/user/XGUY7PRO2/featured

Ms Design :
https://www.youtube.com/channel/UCnwrevLq_aVSGOio4NB809A/featured

12 commentaires:

telemerlin a dit…

l'effet nuage est bien restitué, et comme tu le dis le temps de rendu est super rapide !
merci kami

Rorschach a dit…

de rien ^_^
et en effet c'est beaucoup plus rapide que avec pyrocluster mais c'est de la fausse 3D donc c'est bien de connaitre plusieurs méthode ^_^

Jean VILLEMONT a dit…

super tuto, comme toujours, pas trop compliquer à comprendre ni à réaliser et les effets sont super. Bon week-end à toi! et tous celles et ceux qui regarde la vidéo.
Ps j'ai changer ma photo de profil ;}.

Rorschach a dit…

merci, bon week-end également ^_^

Widy Dedib a dit…

Qu'est-ce que je me suis pris la tête avec les nuages (j'avais la tête dans les nuages, c'est le cas de le dire)... Je vais essayer ça dès que possible, mais je sais déjà que ça va le faire... Merci

Rorschach a dit…

il y a plusieurs façon de faire et celle là est une des plus simple ^_^

patrocle patrocle a dit…

Au secours, urgence!!!
J'ai appliqué ta méthode pour la création des nuages mais il y a un gros problème qui me prends la tête depuis trois jours. Dans le rendu la transparence ne marche pas bien. On voit les bords des images png. Est ce que tu peux s'il te plait m'éclairer sur ce point, c'est urgent. merci d'avance

Patrocle

Rorschach a dit…

As-tu bien modifié dans les réglages de rendu le paramètre "Rayon max." comme je l'indique dans la vidéo tutoriel ? si tu a laisser le paramètre à 15 dès que tu as plus de 15 élément transparent on voit les bords donc il faut augmenter ce paramètre dans le tutoriel je met 200 mais tu peux mettre beaucoup plus si tu as toujours des problème de transparence... ensuite as tu utiliser les mêmes images de nuages que moi ou tu as utilisé d'autres images ? il faut bien choisir les images de nuages si par exemple il y a une bordure non transparente sur ta texture elle sera visible au rendu

patrocle patrocle a dit…

J'ai réglé comme toi le "rayon max." à 200. Non je n'ai pas utilisé les mêmes nuages que toi mais j'ai testé deux images différentes mais le résultat était le même. Comment je peux faire pour t'envoyer mon rendu et jeter un coup d'œil ?

Rorschach a dit…

tu peux uploader ton rendu sur : http://www.zupimages.net et me passer le lien direct vers l'image que Zup Image va t'indiquer ^_^

patrocle patrocle a dit…

http://zupimages.net/up/16/10/duqx.jpg
http://zupimages.net/up/16/10/uq99.jpg

Voici deux images un rendu rapide et une photo d'écran avec la vue du logiciel. Les problèmes sont indiqués sur la première image. Je précise que ces problèmes apparaissent surtout sur la zone de la rivière qui contient elle un matériau de type "Liquid", provenant de la médiathèque du C4D. Avec les flèches rouges tu as le problème des bords qui comme tu vas le constater correspondent au bord de la sélection du cloneur. Les points d'interrogations sont d'autres scories qui apparaissent sans que je puisse savoir d'où elles proviennent. Enfin le cercle en jaune montre le problème de la superposition des textures rivière/nuages. Dis moi si tu as pu visualiser les images et un grand merci pour ton aide.

Rorschach a dit…

Alors, ce que tu indique avec des points d’interrogation cela peux venir que quelque chose qui se reflète dans la texture liquide ou quelque chose qui est en dessous de ta scène le liquide étant un peu transparent, désactive les objet de ta scène un à un pour localiser l'objet qui pose problème

pour la réflexion tu peux gérer cela probablement avec un tag de rendu, on peux cocher ou décocher les réflexions, les ombres, etc.

pour les bords c'est clairement un problème avec l'alpha, je ne rencontre pas ce soucis avec ma version de Cinema 4D, du moins dans mes scènes, par le passé l'objet ciel m'a déjà fait des trucs étrange, peux être essayer de le désactiver temporairement pour voir si il n'est pas le fautif, sinon peut être revoir l'alpha des nuages...

après il y a la solution de passé par une autre méthode pour créer les nuage, par exemple pyrocluster avec les particules...

je n'ai pas trop de solution, booste peut être encore les rayons max, teste avec 500 à la place de 200 vu que c'est un problème d'alpha superposé à une texture de liquide, ça peux aussi valoir le coup de tester le rendu avec le moteur physique si ce n'est pas le cas...