vendredi 6 juillet 2012

Le visualiseur

Un mini tutoriel sur une fonction du visualiseur de Cinema 4D qui permet de charger une série d'image rendu pour les ré-enregistrer sous un format différent comme par exemple un format video




Cette fonction du visualiseur est très utile pour les rendu très long, on fait le rendu en image sans compression donc avec la meilleure qualité possible, on garde la possibilité de stopper le rendu quand on le souhaite et une fois le rendu fini on peur recharger les images dans le visualiseur et sauvegarder en format .mov ou .avi

28 commentaires:

Anonyme a dit…

Très bon tuto sur une fonction du visualisateur que je ne connaissais pas.
Très enrichissant et toujours très bien de vous suivre

Anonyme a dit…

Bonjour,
excellent blog et toujours très bien expliqué, j'en ai appris des choses XD
toutefois j'aurais une petite question au sujet de ce tuto.
voilà, j'aimerais faire un rendu d'une animation avec à la manière de votre tuto mais malheureusement quand j'enregistre les images depuis le visualiseur en video quicktime je pers la couche alpha dans vegas alors que sur mes autres animations en rendu directement en video film quicktime y a pas de probleme.
mes animations sont assez longuent (clip d'une chanson) et j'ai ce fameux probleme de "memoire insuffisante".
y à t'il une solution?
merci de votre reponse

Rorschach a dit…

c'est probablement les options quicktime qui ne sont pas réglé pareil dans le visualiseur et dans les paramètres de rendu, quand tu enregistre avec le visualiseur pense à regarder les reglage quicktime qui sont choisi, pour cela clic sur option à droite de Film Quicktime, puis tu fait tes réglage (image par seconde, images clé, etc.) pour conserver la couche alpha avec la meilleur qualité je conseil de mettre comme type de compression : "sans", le fichier sera plus gros mais il n'y aura aucune dégradation de l'image

avec une compression trop forte la couche alpha est retirée

Anonyme a dit…

pourtant j'ai bien fait attention à faire exactement les memes reglages dans le visualiseur que dans la fenetre de rendu! grrr je comprend pas, mais merci d'avoir repondu aussi vite

Rorschach a dit…

et tes images tu utilise quel format ?

Anonyme a dit…

J'utilise le format TIFF psd pour les images, d'ailleurs quand j'importe toute la séquence d'images dans vegas y a pas de soucis.
Le problème vient seulement lorsque je les enregistrent au format film quicktime via le visualiseur, impossible d'enlever le fond noir dans vegas.

Rorschach a dit…

quand tu transforme tes image en vidéo avec le visualiseur je suppose que tu coche bien "canal alpha"...

le problème ne viendrait il pas plutôt au moment de l'importation du fichier dans Sony Vegas

je vais faire des test pour vérifier cela, pas aujourd'hui je suis débordé, aujourd'hui mais dès que j'ai une minute je test tout ça ^_^

Rorschach a dit…

j'ai pas encore regarder mais juste un truc que je viens de me rappeler pour le quicktime avec alpha il te faut toute la palette de couleur donc dans le champs couleur des réglages du codec quicktime il faut choisir "Millions de couleur +" as tu bien fait cela ? ou tu as laissé sur Optimal ?

Anonyme a dit…

Ah ben justement j'étais entrain d'essayer avec "millions de couleur" à l'instant mais ça ne change rien.
J'ai aussi bien évidement cocher canal alpha dans les réglages.
Je fais exactement les mêmes réglages que pour un rendu directement en quicktime avec le visualiseur, je comprend pas!
J'arrive quand même à faire mon projet mais c'est vrai qu'avec ta technique cela me faciliterait la tâche mais j'ai vraiment besoin du canal alpha pour mes montage.
En tout cas merci beaucoup pour le temps que tu nous consacre à tous;-)

Rorschach a dit…

attention ce n'ets pas "millions de couleur" mais "million de couleur+"
le + est important

Anonyme a dit…

Oui oui c'est bien çà, j'ai oublié le petit " + " dans la phrase de mon commentaire ^^
je referais des tests plus tard, je ne m'avoue pas vaincu aussi facilement ;)

Anonyme a dit…

Bonjour et merci pour les tutos, c'est sympa.

J'aurais voulu savoir à partir de quelle version on peut faire cette manip dans le visualiseur.

Merci beaucoup et encore bravo !

Rorschach a dit…

Dans cette vidéo j'utilise la version 11.5 et ça fonctionne avec les version 12, 13 et 14

pour les version avant le 11.5 je ne sais plus

Anonyme a dit…

Ha ben pas de bol, j'en suis encore à la 10.5
Pas grave, je me servirai d'un autre séquenceur qui permet d'assembler les images en film.

Merci beaucoup pour la réponse rapide ;)

joe care a dit…

bonjour et bravo...ton travail est remarquable et que dire de plus ....sans repeter ce que les autres t' ont déjà dis....je lis toujours les commentaires avant de regarder le tutos et trouve les intervention de "anonyme" très utiles, puisque je possède la r14...en plus il y a parfois des complements interessants à ola vidéo...
Comme anonyme me rend bien service aussi, j' ai peut-être une solution pour lui et son canal alpha...est-il possible de correspondre avec les membre a partir de cette page,

Rorschach a dit…

en effet les petites précisions fournit par le membre anonyme sont utiles je le remercie pour cela ^_^

je ne vois aucun inconvénient à ce que les membres correspondent via les commentaire du blog, cela n'a pas la même efficacité qu'un forum mais j'encourage tout de même le partage de connaissance et l'entraide ^_^

Anonyme a dit…

Bonjour tout d'abord merci pour ce tuto cela fait longtemps que je souhaitais réussir cela mais j'ai garde le même problème de mémoire il faut dire que mon anim est une visite d'une maison décoré (300s)et que 4g de ram virt ne suffit peut être pas en tous cas j'essaye de faire par ex de 0 a 10 image mais le probleme persiste ! je ne comprends pas ?

Rorschach a dit…

sans voir ton fichier .c4d ce n'est pas évident de savoir où se situe le problème, ce qui me vient à l'esprit c'est as tu une configuration assez puissante pour les paramètres de rendu que tu utilise ? utilise tu l'illumination global, l'occlusion ambiante ? des effet particulier qui demande beaucoup de calcul ?, des textures avec transparence ou réflexion ?

Anonyme a dit…

puis je te faire passé mon fichier et comment ?

Rorschach a dit…

tu peux me l'envoyer à ce mail : kamigeek@gmail.com
j'y jetterai un œil dès que j'ai une minute ^_^

Rorschach a dit…

je viens de regarder ton fichier, alors je n'y vois pas de problème, chez moi le rendu des frame 0 à 50 avec anti aliasing au mieux 1x1 et 4x4 met 6 minutes et 42 secondes sur mon core i7 avec 8Go de ram, par contre c'est vrai que le fichier est lourd il y a pas mal de polygone et surtout beaucoup d'objet, or plus il y a d'objet et de polygone plus C4D à besoin de mémoire pour traiter les calculs donc si ta configuration est un peu légère il se peux que cette scène donne du mal à ton PC..
tu peux essayer de dupliquer ta scène et sur le double voir ce que tu peux réduire, par exemple regrouper certains objets polygonaux en un seul (moins d'objet c'est moins de travail), réduire le nombre de polygone en nettoyant les objet de leur polygone de type triangles (moins de triangles c'est moins de calcul aussi)
je pense que si tu optimise un peu plus ta scène tu devrai avoir moins de difficulté à en faire le rendu par exemple tu as plein d'objet Mur (dans Allplan) avec les mêmes texture qui pourrait être regroupés en un seul objet, tu utilise également pas mal d'objet téléchargé il me semble or ces objet sont souvent peu optimisé pour c4d car plein de triangle, il faut les nettoyer, pareil pour les texture attention au texture prise sur le net ou dans la médiathèque elles sont belle parfois mais lourde en temps de calcul, je suppose que ton souci de rendu viens simplement de cela, la scène est trop lourde pour ta configuration, autrement je ne vois pas

Anonyme a dit…

Merci beaucoup pour ton aide et ton avis c'est bien ce que je pensais j'ai encore a apprendre au niveau optimisation mais c'est tellement passionnant !!
encore merci

Anonyme a dit…

Bonjour j'ai donc suivi tes conseils je suis descendu de 130Mo a 106Mo ce qui n'est pas rien .
cela reste quand même trop lourd pour ma config.
j'ai ensuite changer ordi 64bit et 4go ram je m'est plus de temps a faire image par image alors j'ai lancé un film mais j'estime le temps quand même a au moins 5 jours.
je crois qui est temps que je change de config !!!

Rorschach a dit…

passer de 130 Mo à 106 c'est déjà pas mal ^_^
pour info ce qui va compter le plus dans la config c'est la quantité de RAM et surtout le processeur ^_^

Anonyme a dit…

en fait je vais mettre 10 jours a finaliser je ne sait pas comment réduire les polygones et de toute façon ma config est trop faible pourtant
nvidia geforce GTS 250
32 BITS SEVEN
intel icore i5 cpu750 2.67ghz
ram 4go
je vais voir avec un copain il a un mac peut être plus puissant
en tout cas merci pour ton aide j'ai beaucoup appris

Rorschach a dit…

la carte graphique n'influe pas sur la vitesse de rendu, Cinema 4D utilise uniquement le processeur et la RAM perso j'ai un core i7 4770 à 3.4Ghz avec 8Go DDRAM III

Anonyme a dit…

bonjour dit moi est il possible de sauver un rendu film quick time pas fini
genre l’arrêter avant ?

Rorschach a dit…

Alors si tu fait le rendu au format vidéo et que tu arête le rendu avant la fin ton fichier vidéo ne sera pas correctement créer, il y a de très forte chance qu'il ne fonctionne pas ou qu'il fonctionne mal c'est pourquoi je préconise toujours le rendu au format image, ensuite soit avec cinema 4d soit avec un autre logiciel on peux enregistrer la suite d'image au format Quicktime ou avi, le rendu au format image peut être arrêté et relancé alors que le rendu au format vidéo une fois lancé il doit arrivé au bout pour être complet, donc pour répondre à ta question tu peux forcer l'arrêt du rendu mais ton fichier Quicktime ne sera peut être pas utilisable